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1 Driver installation for the Debugger

Connect the Debugger and PC with USB cable, and then the ‘new hardware search window’ will open
as figure 1.1 below.

Select ‘Automatically setup the software (I)’ and click the Next (N) button.

Welcome to the Found New
NQQ\ Hardware Wizard

This wizard helps you install software for:

USE <-> Serial

') If your hardware came with an installation CD
~ug=” or floppy disk. insert it now.

What do you want the wizard to do?

() Install the software automatically (Recommended)
(O Install from a list or specific location [Advanced)

Click Next to continue.

[ Next > ][ Cancel ]

[Fig.1.1] The new hardware search window 1
If it is not automatically installed, select the ‘Install from a list or specific location (Advanced) and set
our attached driver as below.

Please choose your s¢

Select the folder that contains drivers for your hardware.

(#) Search for the be: [ ancamera P
Use the check bo & 8 CompanyWork
paths and remova 2 ) Debugger
P osactiemn = [ CDM 2.04.16 WHQL Certified
) ) amde4
vlnclude this o) i386
DA [+ | & leeys
+ | & MP3
) Don't search. | will} ® MNPKI
Choose this option £ L 2 Office2007 hat
the driver you cho I wizISP_compact_ver1_0 ¥
To view any subfolders, click a plus sign above.
[ OK ] [ Cancel ] _]

[Fig.1.2] The new hardware search window 2

Wait for searching the device driver of the Debugger. When the device driver installation is completed,
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click the END button to finish.

Completing the Found New
Hardware Wizard

&

@ USB Serial Converter

Click Finish ta close the wizard.

Finish

The wizard has finished installing the software for:

Completing the Found New
Hardware Wizard

USE Serial Port

Click Finish to close the wizard.

Finish

The wizard has finished installing the software for:

[Fig.1.3] Completing the new hardware searching #2
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2 Connect the Debugger

This section will explain how the Debugger is connected with iMCU7100EVB. Connect the
Debugger to the DTAG of IMCU7100EVB.

-4 = Reset Button [

[Fig.2.2] W7100A / W7100 Debugger

Connect the other DTAG cable between the Debugger and iMCU7100EVB. The red line of
DTAG cable must be connected to line number 1 of iMCU7100A DTAG socket. Also connect the
USB cable between the Debugger and PC. Next, insert the power cable to the IMCU7100EVB,
and push the EVB reset button as figure 2.1. Then, push the debugger reset button of the
Debugger. Confirm the LED5 (RUN LED) after pushing these reset button.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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If the Debugger successfully recognizes the W7100A / W7100, the LED5 (RUN LED) will turn
on. But if the LED5 is not turned on, it means that W7100A / W7100 is not recognized. Check
the connecting cable or try to reset the IMCU7100EVB and the Debugger. The LED5 should be
turned on before using the W7100A / W7100 Debugger.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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3 Installation of the W7100A / W7100 Debugger

In this section, the installation of W7100A / W7100 Debugger is explained. First, run the
W7100A / W7100 Debugger install file.

W7100Debugger, exe
R ctuo Launcher Unicode

Setup Launcher Unicode
. .I.IIII"lan’t

[Fig.3.1] The W7100A / W7100 Debugger install file

Then the installation of iMCU7100EVB debugger is started. Push the Next button to setup.

Shield Wizard

Welcome to the InstallShield Wizard for
W7100Debugger

The InstallShield{R) Wizard will allow you ta modify, repair, or
remove W7100Debugger. To continue, click Next,

InstallShield Wizard Completed

The InstallShield Wizard has successfully installed
W7100Debugger. Click Finish to exit the wizard.

| FEinis

[Fig.3.3] End of debugger installation
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4 KEIL Project

Projects that are supported by the W7100A / W7100 debugger are as below.
® Keil uVision2 project
® Keil uVision3 project
® Only hex file (Restricted symbol function)

# The W7100A / W7100 Debugger don’t support the KEIL pVision4 or upper version project. But user
can easily convert the pVision4 to pVision3 project as shown in the figure 4.1 to use the W7100A /

W7100 debugger.

File Edit View [Project | Flash Debug Peripherals Tools SVCS Window Help

=" | g‘ New pVision Project... ) ﬁ‘\ FY
& @ New Multi-Project Workspace...
e = Open Project...
roje -
1_7 Close Project ore.c  [.] SERIALH
=323 Target 1 !
=+ Source GummEinark »| Save Project to uVision3 format
[BSTAR  Manage » Save Multi-Project Workspace to iVision3 f
1#) delay [
[flcd.c  Select Device for Target Target 1.
[£] loopt Remove File ‘wizmemcpy.c'
[ main & . 5 . P
S8 M & Optionsfor e wiamemcpy.c.. Save Project to uVision3 format
[#) serial
[# socke Clean target
[ TCP (£ Bua target Save Multi-Project Workspace to pVision3 format EErm oo R L
T W 451 Rebuild all target files
Batch Build... P‘ it's not to be compiled " __ SERIAL UNUSED Block"

<Fig.4.1> Save Project to pVision3 format
% Caution on W7100A / W7100A  Lock function
The W7100A / W7100A has the memory lock function. If the lock was set, user cannot use
the W7100A / W7100 debugger because it cannot read anything from W7100A / W7100A
memory. So user should unlock to use the W7100A / W7100 debugger properly. It is easy to
unlock using the WizISP program. As shown in the figure 4.2, clear the check box and click the
“Lock” button. Whole memory will be erased after the unlocking so user should re-write the
firmware again.
Please refer to the Wiz ISP user manual for more detailed information about WizISP. WizISP

program and user manual are available on the WIZnet website.
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@ WizlSP (v200.0) . - - » & =] o B

Eile  Device Options Help

2 QoHaAaR00 0o

Load HexToBin Program Read Verify Auto Run | Help Exit
COM Port Configuration Hex Editor
Addrss(Hex) 00 01 02 03 04 05 06 07 08 09 OA 0B OC OD OE OF 0123456789ABCDEF
Port: |Ccom4 L)

FEFFE FEOFE FFFE FFFE FFFE FEOFE FF-FE . ...............

= & Flash Operation Mode oo ove e

Baud: [115200

Flash Operation Mode

@ Code ) Data

B oo
ERE RN

gk Code . Data Set .............

TR S 1S 2s S SE T e [n
<Fig.4.2> Unlock the W7100A / W7100A using WizISP program

The W7100A / W7100 debugger cannot recognize multi directory structure of KEIL project
so all project file and source file must be placed in same directory to use W7100A / W7100
debugger. And the ‘make hex file’ option and ‘make symbol’ option should be activated in
the KEIL project. If they are not activated, the W7100A / W7100 debugger cannot find the hex
file to load. Also, an error message could appear even if it finds the hex file.

Since the W7100A / W7100 debugger use slower clock than normal running clock, running
speed under the debugging mode is very slow. So we recommend that don’t use a delay

function or something like that.

First, open the KEIL project.

Click ‘Project’ => ‘Options for Target ‘Target name’ menu.

[¥] Code [¥] Data -m 00000070 [I| FE: R FF I et e e i e e o (. o oo o mee oiaiaae L
i i 00000020 | == 7 r¢ | [ Code [7] Data Bl ] D 3
Auto Task Selection 00000090 | FEFFFF R o M.
[¥] 1. Flash Erase 00000080 | FF FF FF e o @ et e s s s s s aan
00000080 | FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF .o v v v e ve e en e
[] 2. Blank Check 000000C0 | FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF . v v v v v i en e e
[¥] 3. Program 000000D0 | FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF . . ¢t ittt v e v o a e a
@) 4, Verity 000000E0 | FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF 2 v e v n e ve e en e
000000F0 | FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF 2 v v v v v e om e e nnn -
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k£ Test_Driver - Sision3 =10 x|

File Edit View [Project] Debug Flash Peripherals Tools SYCS Window Help

E-£5 Source Group |
[#] STARTUR, 251
farmerncpy,c
rain,
serial,c
socket c
wil00,c

BesH@ s mR|oo|EE o %K A ~l[¢a]
«+> @& a(BEo e m

%@ ¥ ﬂa;‘;’QITar!;|w3t1 j T =

[Project Workspace - x|

=34 Target |

Blsax |9

= -
: 4
&

2

=

a -|
g 4 I 4 I }I il I'\ Build .& Command }\ Find in Files ," ” A I »

[Fig.4.3] Open the KEIL project

Check the ‘Create HEX File’ option from the ‘Output’ tap as figure 4.2.

Options for Target "Target 1° =l

Device | Target Output |Listing | User | C51 | #81 | BLS1 Locate | BLS! Misc | Debug | Utilities |

Select Folder for Objects. . | Mame of E xecutable: ITest_Driver

% [Create Executable; W Test Driver

W Debug Information W Browse Information

R Create HEXFile  jes Fomat [HEx20 4|

" Create Library: AT est_Driver.LIB [ Create Batch File

aK || Cancel || Defaults I

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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[Fig.4.4] Output tap of the ‘Options for Target’ window

Select the ‘Listing’ tap and check the ‘Symbols’ option of the ‘C Compiler Listing’ region.

Options for Target "Target 1° x|

Device | Target| Output Listing |User | CBI | 481 | BL5! Locate | BL5! Misc | Debug | Utilities |

Select Folder for Listings... | Page 'wiidth: I'I 20 _|::' Page Length: IBE _1::'

[V C Compiler Listing: . lst
¥ Conditional

[ #Hinclude Files [ Assembly Code

[" C Preprocessor Listing: M= ‘

¥ #zzembler Listing: st

¥ Conditional W Symbals Macros: IFinaI expansion only 'I [" Cross Reference

V¥ Linker Listing: T est_Driver.mS1

V¥ Memary Map [V Public Symbols [V Line Numbers [ Cross Reference

W Local Symbals ¥ Comment Recards ¥ Generated Symbols
[v Library Symbols

0K I Cancel | Defaults | Help |

[Fig.4.5] Listing tap of the ‘Options for Target’ window

Also check the ‘Symbols’ option of the ‘Assembler Listing’ region. The ‘Assembler Listing’ is optional.

Click the ‘OK’ button to finish, and compile the KEIL project.

Confirm the HEX file in the project directory after compiling.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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&= C:\LOOPBACK_TCP

File Edit WYiew

eBack = Q

Favorites

Tools Help

L” psearch [C Folders

Address |[23) C:\LOOPBACK_TCP

File and Folder Tasks

®[} Rename this file

[y Move this file

[D Copy this file

&) Publish this file to the Web
() E-mail this file

¥ Delete this file

Other Places

e Local Disk {C:)

() My Documents
| Shared Documents
J My Computer

& 1y Network Places

Details

= ‘_l L_l =
loopback loopback LOOPBACK LOOPBACK
LOOPBACK LOOPBACK LOOPBACK.hex LOOPBACK.Inp
loopback.LST LOOPBACK.MAP LOOPBACK.Opt LOOPBACK_Opt.Bak

[

[Fig.4.6] Hex file of the KEIL project

If the KEIL project includes the assembly code such as xxx.SRC file, the ‘Generate Assemble
SRC File’ and ‘Assembler SRC File’ options must be checked.

First, open the Options for File ‘xxx.c’ that uses the Assemble code.

B File Edit View Project Debug Flash Peripherals Tools SVCS Window Help

PNeEH@| R | D

s o kw66 a0 0”@

e |5 K Target AT ®
[Project Workspace < x

B89 Target 1
B-E3 Source Group 1

W7100 driver

(c)COPYRIGHT WiZnet Inc. ALL RIGHT RESERVED

e

- [#] STARTUP.AS1

+/

RS:‘E.‘&SE%B?BB%

@file wizmemcpy .c
@rief Define memory copy function between MCU memory and TCPIPCore memory
+

#include "w7100.h"

13 | #include “wizmemcpy.h”
1; #include "TCPIPCore.h”
1

Options for File 'wi: c

£ | #datina RENFRAI 4DD

Open #wizmemcpy.Ist
File
Open wizmemcpy.c
[ Rebuild all target files
(%] Build target
%

Stop build

New Group

Add Files to Group

&4 Manage Components
Remove File 'wizmemcpy.c'

Include Dependencies

Translate D:#WIZnet#_PurplewW7100%_ W7100_Appli

tion_Note_I

TCPH#TCPs ifi i py.

42 EA = EAback;

43 DPX0 = tmp_DPX0;
44

45 | #else

46

|«T |

I»]

ETEFREEE

B delay.c wizmem,.,l

[Fig.4.7] Open the Options for File

‘xxx.c’

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved.
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Then, check the ‘Generate Assembler SRC File’ and ‘Assemble SRC File’ options.

r " —h)
Options for File ‘wizmemcpy.c' M
Properties |C51 |
Path: ]D:WW]ZnefW-_PurpleWW?lUUW_-WTIDIJ-AppIication_Note_IntegratedVeMApplicationsWTCPWTCPs
File Type: [C Source file ~| 7 “Target Build:
Size: (2019 Bytes [Z Always Build
last change: IFl’i Apr 22 17:15:26 2011 [v Generate Assembler SRC Fil
[l v Assemble SAC File
i 7 Link Publics Only
Code Bank: v
|| Stop on Exit Code: |Not specified |
] Select Modules
to Always
Include:
Custom Argurnents: |
| |
=0l FHa | Defaults I T2

[Fig.4.8] Setting the Options for File ‘xxx.c’

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved.
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5 Debugger menu

5.1  Open project

The W7100A / W7100 debugger can debug the KEIL project or the hex file. To debug the

KEIL project or the hex file, run the W7100A / W7100 debugger and open the hex file.

Open Project.

The Open Project command is used to open a project.

Click the ﬁ icon of the toolbar. It can also be done by clicking Project Menu => Open or

pushing the short key Ctrl + O

The file open browser is opened as figure 5.2 ‘File open browser.’

Fzea TTi aEeEsREEEEE & .
o ( BHEM PO V| p WE[ES B
Register 2 x
+ (74 project : Empty |Register |
©=z: Al
@ Z
Register Value
B Default Registers -
RO 0x00
R1 0x00
R2 0x00
A3 0x00
R4 0x00
RS 0x00
RE 0x00
R7 0x00
A 0x00
R nenn -]
| Assembly | [Search =
ok
Name | Walue | Type | Addres: A
v
<] >
Els.. |[@L. [&e. [@s. |[Eo. /@ e. @ r. &c. |
Ready NU

[Fig.5.3] Open project

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved.
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. W7100 Debugger

Project  Help

PEERR3EEEED .|

Lookir: |2 LOOPBACK_TCP ~ « ®merE-
: 2 LOOPBACK hex

My Recent
Documents

€]

Desktop

My Documents

My Computer

-

My Network — File name: LOOPBACK M Open
Places l _] —l
Files of type: |HEX Flle [ hex) ~| Cancel |

[Fig.5.2] File open browser
If the user opens the project that is consisted only with a HEX file, the Debugger will show

a caution message. And it shows only ‘Assembly window’.

5l [CIMAING | [c] FARMEMCPY.C | [c] STARTUP.AS1 X
7 project : Test_Driver |Register ~
- B Source Files 117 2STACK SEGMENT  IDATA Al i
¢ MAIN,C 118 o ) @ Z
¢4 FARMEMCPY.C 119 | RSEG ?83TACK Register Yalue
¢ STARTUP, 451 120 i DS 1 B Default Registers a
121 RO 0x00
122 | EXTRN CODE (?C_START) Rl 000
123 i i i 1 [ PUBLIC 2C_STARTUP Rz (=00
124 R3 0x00
125 i1 1 i icsEe AT 00000H R4 000
126 §»?C_STARTUP: LIMP STARTUPL A5 0x00
= RE 0x00
128 i i 1 i I RSEG ?2¢ CS518TARTUPR %
I - A 0x00
123 ) flonn hd
130 STARTUPL:
aliehl i1 1 ANL OFFH, #07FH v
<] 2|
hesznbly Searcy R
| Assembly ~| [Search =
ok
126 : 2C_STARTUP: Lo sTarTU | [ Name | Value | Type | Address [[a
0> 0x0000 02001E LIMP LOOOL
0x000b 020126 LIMP LOOOD
0x001b  02015E LIMP LOOOD
131 : ANL OFFH, #07FH
0x00le S3FF7F LOOOL: ANL OFFh #7Fh | v
134 : wov o e v| &lSe.. Eo. (@Gl | sy.. |Eoe.E ex. [ F.. &co.. |
Ready NUM

[Fig.5.3] Complete opening the project
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*Note: When the user open the project and have the error message like shown below, the user must
delete the xxx.SRC file in project directory, and check both the ‘Generate Assembler SRC File’ and
‘Assemble SRC File’ options to avoid error on the W7100A / W7100 debugger.

For a more detailed solution, please refer to section4 ‘KEIL Project’.

W7100 Debugger

' ORtion error!! uVision Project Workspace-> FARMEMCPY.C file-> Click right mouse button -> Select "Option for File
o FARMEMCPY,C" -> Check 'Generate Assembler SRC" file and "Assemble SRC file’ in Properties tab

[Fig.5.4] Open error message

Reload project
The Reload command is used to reload a project. When the loaded project is changed, click
the reload toolbar button [#] to reload the project. It can also be done by clicking ‘Project’

=> ‘Reload’ or pushing the short key F4.

Close project
The Close project command is used to close a project. Select ‘Project’ => ‘Close’ or push
the short key Ctrl + Q.

*Note: While using the W7100A / W7100 debugger, the user must use the ‘stop’ command in

order to close the debugger.

5.2 Initialize the W7100A / W7100 Debugger

This section is for initialization of the debugger and iMCU7100EVB
WY100 Debugger - STARTUP, A51

ZE B TTH EEgFgP3EEEEIF.
: DWMPON » @=E(=EE(

[Fig.5.5] Initialize menu

>

p—

¢
[

Debugger and board reset
The Debugger and board reset command is used to reset the debugger and board
simultaneously. If breakpoints were set, all initialized breakpoints will be removed.
To reset, click the E]; button on the toolbar, or select ‘Tool menu’ => ‘Init Debugger and

Board reset’ menu. Then the Debugger and board will reset.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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Board reset only
The Board reset command only is used to reset the board only. If breakpoints were set, they
will be maintained. To reset the board, click the E’] button of the toolbar or select the

‘Debug menu’ => ‘Board reset’. It can also be done by short key F2.

Image load

The Image load command is used to load an image.

Write the HEX image for debugging to the Flash memory.

Click the H'E, button or select Debug menu => Image Load menu to execute ‘Image Load.’
It can also be done by short key F3.

If the image writing and verifying is successful, ‘Write OK’ message will show.

Note: If there is a mismatch between the board image file and present HEX file, the error

message is shown when execute the ‘Debugger commands’ such as ‘Continue, Step, Next’.

W7100 Debugger

'E Error!! Load Image mismatch, please reload Image,
-

[Fig.5.6] Load image mismatch
Debugging

The W7100A / W7100 Debugger serves ‘Debug’ and ‘Tool’ menu and Toolbar button for
debugging.

W7100 Debugger - STARTUP, 251

55 B TTI JE843EEEB0 5.
S @HOO® » @5=(=5=(zs |

[Fig.5.7] Deugging menu

Go to Source Line
The Go to Source Line command is used to move the cursor to the wanted source line. To use this

function, select the ‘Tool’ menu => ‘Go to Source Line’ or use short key Ctrl + G.

Find
The Find command is used to find some words on the source window. To use this function, select the

‘Tool’ menu => ‘Find’ or use short key Ctrl + F.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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5.3 Run and Stop

This section will explain how to use commands like step in, out, next, and more
Continue
The Continue command runs the program until the Break point is met. To use this command,
click the [ button on the toolbar or select the Debug menu => Continue. It can also be
done by short key F5.
During the Continuing state, user cannot use the debugging menu. In order to use the

debugging menu, execute the Stop command.

Stop

The Stop command is used to stop the running program. To use this command, click the

d  button on the toolbar or select the Debug menu => Stop. It can also be done by short
key F6.

The debugging commands (Search, memory view, break point, etc.) are executed only in the Stop state.

Step
The step command is used to run only one specific line among all lines. The Step command is executed
in units of one line of the C code. If there is a Function call, the Step command will enter into the
related Function. After the execution, the debugger is stopped and waits for the next command.
To use this command, click the button on the toolbar or select the Debug menu => Step. It
can also be done by short key F11.  *E If the user has only the HEX file to debug, the

Step command executes one instruction, just like the Stepi command.

Next

The Next command is basically the same as the Step command. The Next command is executed in units
of one line of the C code. But if there is a Function call, the Next command does not enter into the
Function. After the execution, the debugger is stopped and waits for the next command.

To use this command, click the button on the toolbar or select the Debug menu => Next. It
can also be done by short key [= F10. If the user has only the HEX file to debug, the

Step command executes one instruction, just like the Nexti command.

Stepi
The Stepi command executes only one instruction. If the instruction is a Function call, the command

enters into the related Function. After the execution, the debugger is stopped and waits for the next

command.
To use this command click the button on the toolbar or select the Debug menu => Stepi. It

can also be done by short key F7.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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Nexti

The Nexti command executes one instruction. But the command does not enter into the related
Function even if the instruction is a Function call. After its execution, the debugger is stopped and waits
for next command.

To use this command click the = button or select the Debug menu => Nexti.

It can also be done by short key F6.

Run to cursor line

The ‘Run to cursor line’ command executes the code until the cursor on the debugger source window is
met.

To use this command, select the push the mouse right button => select ‘Run To Cursor Line(n)’ or

select the Debug Menu => Run To Cursor Line.

-

1 S=E(ESE(=

CWT00.C | [c] SOCKET.C | €] SERIALC | [c] MAIN.C x | [c] FaR

55

56 uint8 xdata txsize[MAX SOCE NUM
57 uint8 xdata rxsize[MAX SOCE NUM
S8

55 whil=f{1) =

60 Goto Source Line(L)

61 et Break(B) tialize 8
g2 Insert Variable Window(\)

63 Fun To Cursor Line{M}

6d setSHER (mac] ;

] sstGAR (gw) ;

o6 =22t SUBR (=n) ;

=7 =TI TTTE £ 2t o

[Fig.5.8] Run To Cursor Line command

Sometimes the ‘Run To Cursor Line’ command continues when the cursor is not properly set.

If that is the case, execute the Stop command to stop it.
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5.4 Break Point

This section will explain how to set/clear and find breakpoints. The breakpoint can be set
only when the debugger is not being used. If the user was using the debugger, use the Stop

command to stop in order to set the breakpoint.

Project Tool Window Environment Help
EE G TTH AR 3EEEEHEK,
i 2 SB[ wronc | (6] SOCKET.C | [€] SERIALG | €] MAIN.C x} ] FARMEMCRY,C | (€] STARTUP 481
== project : test_driver - [Feglster =]
=5 Source Flles 49 // uint8 xdata tmplé] = {0,0,0,0,0,0}; ~ T Al
o4 WH00.C S0 e
& SOCKET.C 51 uint8 xdata ip[4] = {192,168,1,86}; // fo: Fegister Yalug
& SERIAL.C sd®| uwints xdata gw(4] = [192,168,1,1}; // £ | @ Default Registers =
o] MAIN,C 538 uintd xdata sn[4] = {255,255,255,0}; 1/ RO Oxf9 _
&+ FARMEMCPY,C 549 uint8 xdata mac[E] = [0x00,0x08, 0xDC, 0xll, 0x22, Ox8E); | Rl Ox16
€ STARTUP. 451 59 FR2 (0 iy
54 uintf xdata txsize [MAX SOCK NUM] = {2,2,2,2,2,2,2,2}; W R3 Ot
sq1@ uint8 xdata rxsize[MARX_SOCE_NUM] = {2,2,2,2,2,2,2,2}; :; gmnan
58— "
5 FE 0:08
o] Init8051();  // Initialize 8051 27 g:%g
&1 iinchip_init(); B 050
&3 ) P 061
6 setS8HAR (mac) ; DPTRO (7700
64 =etGAR (gw) ; PC§ O 00dc
6 3etSUBR(=n) ; 2 PSW ﬂ
[ =etSIPR(ip);
6] | sysinit (txsize, rxsize); v
< |
[Ty, 5 xTerearant
Assembly ~ | |[BreakPaint -
o X @l
Ux0059  79C9 WOV EI #0C9R Name [ Latel =
0x005k  7E00 MOV R& #0h = IN.C . Line + /4 main + 2111 b
AIM.C . Ling @ 52 main + 19
0x005d 7FOE MOV R7 #8h AIM.C . Line @ 53 main + 3
AIM.C . Line @ 54 main + 57
0x005f 120950 LCALL L0016 AIM.C . Ling : 55 main + 7
AIM.C . Ling @ 57 main + 95
57 uintd xdata rxsize[MBX SOCK_NUM] = (2,2,%,2,%,2,2,2 AIM.C , Line : 57 main + 87
AIM.C . Ling @ 57 main + 53
0x0062 7884 MOV RO $84h AIM.C . Ling @ 57 rmain + 101
R AIM.C | Line : 57 main + 105
020064 7C00 MOV B4 #0n AIN.E | Cine : 57 main + 103 3
0x0066 7DOL MOV RS #1h
0x0068 TBFF MOV R3 #0FFh
0x006a TAOE MOV RZ $0Eh
0x006c 7901 MOV R1 #0D1h
0x006e  7E0D MOV BE #0n
0x0070 TEOE MOV RT #2h
~
0x0072 12095D LCALL 10016 !
e & jErEak‘..JaSearchlﬂlData‘.lﬂ Exter‘..lﬂ Flas”.JEG\UD.H l@cme..‘l,ﬁlswnm ﬂ\_ucal‘..l
Ready

[Fig.5.9] Break point of the debugger

Set break point

To set the breakpoint
1. Click the shadowed region side of the source window
2. Locate the cursor and click the g utton on the Toolbar
3. Locate the cursor and click the Debug Menu => ‘Set Break’
4. Double click the C code line in the source window
5. Double click the Assembly code line in the Assembly window
6. Locate the cursor in the Assembly window and click the _3 he Assembly Toolbar
7. Short key F9

Set the breakpoint and execute the Continue command. Then the debugger will run until it

meets the breakpoint and will stop at the checked breakpoint. After that, the user can use
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other Debug commands. If the PC(program counter) can’t move to the breakpoint, the
debugger will keep running. If that is the case, the user should execute the Stop command to

stop it.

Clear Break
The Clear command is used to clear the breakpoint.
1. Click the checked breakpoint . region
. Click the ' _} button on the selected breakpoint line
. Locate the cursor at the C code line and click the Debug Menu => Clear Break
. Double click the breakpoint directly on the C code line

. Double click the breakpoint directly on the Assembly code line

o U AW N

. Select the breakpoint on the Assembly code line and click the & button

on the Assembly Toolbar

7. Select the breakpoint on the C code line and select the #& button on the Breakpoint
Toolbar

8. Short key F9

Clear All Breaks
The clear all breaks command will clear all breakpoints, both from the C code and Assembly
code. To clear all breakpoints,
® Click the ,:'J button on the Breakpoint Toolbar (Breakpoint window)
® C(Click the ;;-J button on the Toolbar

® Select the ‘Debug’ menu => ‘Clear All Breaks’

Goto Next Break Point

The Goto Next Break Point Command is used to move the cursor to the next break point.
To use this function,

Click the [ button on the Toolbar

Select the ‘Tool’ menu => ‘Goto Next Break Point’

Goto Previous Break Point

The Goto Previous Break Point command will move the cursor to the previous break point. To use this
function,

Click the Qa-‘ button on the Toolbar

Select the ‘Tool’ menu => ‘Goto Pre Break Point’
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Break Point Window
The Break Point Window command shows all checked breakpoints.
The break point Toolbar buttons are as below.
® I : Clear the selected breakpoint
® 3 : Clear all breakpoints

® 4| : Move to selected breakpoint

Source and Assembly window
In the Source window and Assembly window, user can see the source code and assembly

code. The user can also use Debug commands.

In the source window, user can check all variables and add it to the search window.
W7100 Debugger - STARTUP, 51

EE 38 TTH sdsaz3na=dags.
& BWMOO® » @a=(Fo=(z-z .

[Fig.5.10] Window menu

To use the Assembly window, click the j button on the Toolbar or select the Window

Menu => Assembly menu. The Source window is always shown unless opening only HEX file.

Source Window

e | ) sockeT.c | (¢ SERIALC | (] MAIN.C x| [c] FARMEMCPY.C | [c] STARTUP,AS1

48 // uint8 sn_sr tmp, sn_mr_tmp; ~
459 // uint8® =data tmpl€] = {0,0,0,0,0,0};

S0

51 uintl =xdata 1p[4] = {1%2,168,1,86}; /i fo:
52. uint8 =xdata gw([4] = {1%2,168,1,1}; /4 £
s2 @ uintf8 xdata sn[4] = {255,255,255,0}; Iy
54 . uintf8 xdata mac[6&] = {0x00,0x08, 0xDC, 0x11, 0x22, 086} ;

S5

56 uintf xdata txsize[MAX SOCK NUM] = {2,2,2,2,2,2,2,2}; E
57 0> uint8 xdata rxeize[MAX SOCK NUM] = {2,2,2,2,2,2,2,2};

:g | Gota Source Line(L)

60 Initaps] SetBreakil) 8051

61 iinchip Inzert Variable Windowi})

&2 Fun To Curgor Line (M)

63 =etSHAR (mac) ;

o4 setGAR (gw) ;

65 =2t 3UBR (=n) ;

oy | setSIER (ip) ;

&7 sysinit (txsize, rusize);

68

&s i@ ButStringln | "====================================" ;

70 PutStringln (" W7100 Net Config Information"); v

< |

|

[Fig.5.11] Source Window menu

The Source window is shown in the figure 5.11.

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1

22

apino 18bbngaq 00TLM / VOOTLM



"‘?IZnet

° L{} : indicates the PC (Program Counter) in the source code
° . : means Breakpoint is set on this line
° : the breakpoint can only be set on this shadowed line

Click the mouse right button in the Source window, user can see the Source window menu
as in the figure5.11.

® Goto source line: Move the cursor to the set line

® Set break: Set the breakpoint

® Insert Variable window: Add the variable to the Search window
°

Run To Cursor Line: Run the C code to cursor line

Moreover, the Source window can assist some functions as below.
® Can set the breakpoint by double clicking the C code.

® Show the indicated variable value when the mouse pointer on the variable.

Assembly window
The assembly window shows the currently running assembly code. Also if the user clicks the C code at
the source window, it shows the related assembly codes. If the user opens only the HEX file without Keil

project files, only the assembly window will be shown without the source window.

|Assembly ]
)
0x0044 7TROE MOV R2 #0Eh 25
0x0046 79C3 MOV R1 #0C3h
0x0048 7TEO0O MOV RE& #0h
0x004a 7FO0& MOV R7 #6h
0x004c 12085D LCALL LOOLlé&
56 uintd xdata txsize [MAX S50CK_NUM] = {2,2,2,2,2,2,2,2};
ﬂ 0x004f 7a&7C MOV RO #7Ch
. 0x0051 7C00 MOV R4 #0h
0x0053 7001 MOV RS #1h
0x0055 7TBFF MOV B3 #0FFh
0x0057 TROE MOV R2 #0Eh
0x0059 79C9 MOV R1 #0C9h
0x005k 7TEQO MOV RE& #0h
0x005d4 7FOS8 MOV R7 #Eh
0x005f 120950 LCALL LOOLlé&

[Fig.5.12] Assembly window
In figure5.12,
[ L{} : Indicates the PC’s location of the instruction

] . : Indicates the break point

L] __=' : Shows the assemble code with related C code
°

°

_3 : Shows the break point

double click: Sets or unsets the break point
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6 Search & Variable Window

The W7100A / W7100 debugger provides various windows to see the local variable, global

variable, and the register value.

Global variable window: Shows the value of global variable in the project

Local variable window: Shows the value of local variable at the PC(program counter)
now

Search window: Puts the variable name, then it shows the value at the PC now

Register window: Shows the value of registers at the PC now

Symbol window: Shows the all symbols and its values of the project

To activate each window, select the related window on the Window menu or click the

window button on the Toolbar.

W7100 Debugger - STARTUP, 51

[Fig.5.13] Search window

® Activate Search window: Click the ,ﬁj or select the ‘Search Window’ on the Window
Menu

® Activate Local variable window: Click the _ﬂ or select the ‘Local Variable Window’
on the Window Menu

® Activate Global variable window: Click the ﬂ or select the ‘Global Variable
Window’ on the Window Menu

® Activate Symbol window: Click the -_I-Ehl-vor select the ‘Global Variable Window’ on
the Window Menu

® Activate Register window: Click the f]j' or select the ‘Register Window’ on the

Window Menu

6.1 Search Window

The search window shows the global variable, local variable, or the memory value,
depending on which ones the user registered. The global/local variable windows also show
the values of variables. But usually users want to see one or two variable values and
sometimes want to see both global and local variables simultaneously. In this case, just

register the variables on the search window.
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Search -
Marne | Walue [ Tvpe | Address [ -
D0 00:4 249, 42, 14, 255 ARRAY

Ci0x00:4 2,18, 106, 120 ARRAY

Aolxbad 192, 168, 1. 86 ARRA&Y E
5 4 J_CH&R 00000008

len 0 INT 00000009

[Fig.5.14] Search windows

To register the global/local variables, write down the register name on the name field of
the search window.

On the search window, user can not only confirm the variable but also can modify its value.
To modify the value of the variable, click the value field on the search window and write
down the value.

To see the memory value on the search window, write in the form, ‘memory type :
address : size.” The memory types are C, D, and X. (code memory, internal data memory and

external data memory).

Ex) Code memory => C:0x1000:5
Internal memory => D:0x30:2

External memory => E:0x000300:4

Local “ariable

|Search -
MName | “alue | Type | Address [ ~
5 1] I_CH&R D:0x000008
i 1] U_CHAR BINARY  (B) )
j a U_CHAR OCTAWD  (O)
ip 192,168,1.86 SRRAAY
gw 192°166.1.1 ARRAY DECIMAL (D)
=N 205,255, 255,0 ARRAY HEX, ()
mac 0.8.220.17.34,,.,  ARRAY UATIIOUTD
tisize 2.222222%2 ARRAY Filw00007C
resize 22222222 SRRAY Felw0000s4
W

=]iData Memo,,,lg’]Glnhal Vari,,,la@Symhol IECUde Memo,,,lﬂ External M,,,li]anal Varia,,,lﬂSearch ‘

[Fig.6.1] Display format

User can select the display format by clicking the mouse right button on the search, local

and global window such as binary, octal, decimal and hexadecimal.
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6.2 Local Variable Window

The local variable window shows the value of the local variable in the PC located function.

Search -
Marne | Walue | Tupe | Address | ~
g 4 U_CHAR D:0x000005
len 1] IMNT D:0x000009
i 0 U_CH&R D:0x000008
ip 192,168.1.86 ARAAY wi0x 000064
gy 192,165.1,1 SRAAY = 0x00006E
sn 256,255, 255.0 ARRAY ¥:0%000072
mac 0.8.220,17.34,,.. ARRAY #:0x000075
tysize e.eeeeeee  BRRAY Fi0x 00007
rasize 22222222 ARRAY *:0x000084
W

[Fig.6.2] Local variable window
The local variable window has almost the same interface as the search window. But it is not

allowed to register a new variable or a memory address.

6.3 Global Variable Window

The global variable window shows all the global variables in the project. The global
variable window has the same interface as the local variable window.

Global Variable -
Mame [ Yalue | Type | Address [

data_buf 20672 PTR D:0:00005F

local_port 33823 U_IMT 0000099

read_addr_h 54 U_CHAR 0000065

read _addr_| 132 U_CHAR 0000069

[Fig.6.3] Global variable window

6.4 Symbol window

The symbol window shows the information of all symbols in the project. It shows the class

type and the address of the related symbol.
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Symbnl -
Hame | Class Type | Address | ~

-|fa ?C_STARTUP

YC_STARTUFR FUBLIC C: 0000000
ACC SFRSTH D: 0=0000ED
E SFRSTH D:0=0000F0
DFH SFRSYH D:0=000083
DFL SFRSYH D:0=000082
IDATALOOE SYMEOL C:0=00126D
PPAGE SFE SFRESTH D 0=x000040
=13 SFRESTH D 0x000081

SYMEOL C:0=001264

.
-IgE MATH
_ICE DUMMY_ SYMBOL C:0x=000000
@& po SFRSYH D:0=000080
& SFRSTH D:0x=000030
P2 SFRSTH D:0x000040
P3 SFRSTH D: 0x0000B0
IE SFRSYH D:0x000048
IF SFRSYH D: 0=0000B8
I I PITRT T - N==00N0N0M073 v

6.5

[Fig.6.4] Symbol window

Register window

apino 18bbngaq 00TLM / VOOTLM

In the register window, user can check or modify the value of the register. It shows the
default registers, PSW, and special function register (SFR). To modify the value of the register,
click the field of register value and write the new value. But if the register is read only, then

the value is not changed.

Register -
oF 2
Register Walue
= Default Registers -
RO 0xf9 ]
R1 Ox2a
R2 (0x0e
A3 Oxff
R4 0214
RS 004
RE 044
R7 0x14
A 0xfd
B 0=07
SR 0x61
DPTRO 00344
PC § 0x0211
B PSW
P 1
0
[ 0
RS 0
FO 0
AC 0
[ 0
B Speicial Registers
PO Off —
DPL 003
DPH 044
DPTRI 0x0000
DPs 000
PCOMN 080
TCOM Oxc0
TMOD 0x20
TLO 000
TL1 Oxfe
THO 000

[Fig.6.5] Register window
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7 Memory window

Notice: To read a memory value of iIMCU7100EVB, a Keil project or HEX file should be
opened first. To read a memory value of iMCU7100EVB, any Keil project or HEX file
should be opened first. But there are no differences between Keil project or HEX file
and image file which loaded to iMCU7100EVB.

The iMCU7100API debugger supports below memory windows.
° IData memory window: Shows the value of internal data memory. Update the
value when stop state after the debugger command
External memory window: Shows the value of external data memory
Code memory window: Shows the value of code memory

Flash memory window: Shows the value of flash memory

To activate each window, use the ‘Window’ menu and Toolbar as in the figure7.1.
W7100 Debugger - STARTUP, A51

FE B3&a TTHN 2= &8

$: @WMPOW » @aE=E(E=E(z=,

[Fig.7.1] Memory window

[ Activate IData memory window: Click the i button or select the ‘Window’
menu => ‘IData Memory Window’

® Activate External memory window: Click the E button or select the
‘Window’ menu => ‘External Memory Window’

® Activate Code memory window: Click the E button or select the ‘Window’
menu => ‘Code Memory Window’

] Activate Flash memory window: Click the ﬂ button or select the ‘Window’

menu => ‘Flash Memory Window’
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7.1

The IData memory window can show the value of internal data memory (D:0x00 ~ D:0xFF)

or modify the value.

IData Memory Window

IData Memory

2] (4] [¢]

hddress | o123 | 4567 |  @9aE | CDEF »
0=000000 FI92A0EFF 14044414 04000000 0701128F

0x000010 00070008 40004000 00000000 DO0O00000

0x000020 00000000 00000000 00000000 D0000000

0x000030 00000000 00000000 00000000 D0000000

0x000040 00000000 00000000 00000000 D0000000

0x000050 00000000 00000000 00000000 D0000070

0x000060 00000202 ©4193516 00000000 DO0O0O00OD

0x000070 00000000 00000000 00000000 O0000000

0x000080 FFE10344 00000080 COZ000FE  OOFCO100

0x000090 FFOOODG00 00000000  SO000000 00000000

0x0000a0 FFOOOOOO 00000000 00000000 00000000

0x000080 FFOOOOOO 00000000 00000000 00000000 "

apino 18bbngaq 00TLM / VOOTLM

[Fig.7.2] IData Memory window
To modify the value of internal data memory, click the value field of internal data memory
and write the new value. All memory windows can change into the display format, such as
2/4/8 byte display unit or CHAR/INT/LONG display format. It is shown in figure7.3.

IData Memaory

Start Address: l:l End &ddress: l:l

2] (4] [a]

Address |  o1za | 4567 |  @9ae |  CDEF | ~
0000000 62000000 00000100 00000000 00000000

0000010 00000000 00000000 00000000 00000000

0x000020 00000000 00000000 00000000 00000000

02000040 - §|  CHARICH  EnETinT

0000050 anoooooo o INTD 100000 00000000

0000060 70000000 O | QNG 000000 00000000

0000070 Q0000000  Jommmoreros s eed00000 00000000

0x000080 :  FF62FEl& 00000000 00000000 00000700

0x000090 :  FFOOO700 00000000 00000000 00000000

0x000020 :  FFOODODOOO 00000000 00000000 00000000 2

| =iData Memu...l_}f] Global Vari...l,‘é"_,Symbol lﬁCnde Memo...lﬂ External ... l E] Local Varia...l,;'ﬁ Search ‘

[Fig.7.3] Change the display format
If the internal data memory value updates and the debugger command is in stop state, it

updates the internal data memory value to the iMCU7100API board.

7.2

The external data memory window shows the value of external data memory (X:0x000000 -~
X:0xFFFFFF).

External Data Memory Window
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Address | 0123 | 4587 | 948 | CDEF | ~
0x000000 07FFO07FF  07FFO07FF  07FFO7FF  07FFO7EF
0x000010 07FFO07FF  07FFO07FF  07FFO7FF  07FFO7EF
0x000020 02000800 08000800 OSO00800 OS000S00
0x000030 02000800 08000800 OS000800  OS000S00
0x000040 CFO03217F 3C266GEE  COOOCE0O0  DOOODS0OO
0x000050 EOODES00  FOOOFS00  SO000SS00 90009200
0x000060 A000AS00  EBOOOBS00  3684C0AS 01GECOAS
0x000070 0101FFFF FFOO0O00S DC112286 02020202
0x000080 02020202 02020202 02020202  01423Dac
0x000090 - 20008320 16270CEE C4841FFC  714E82E4
0000020 - 9500F99F 4E076809  4D28A830  2124BFSS

[Fig.7.4] External Data memory window
The value of external data memory is not automatically updated. If the value of external
data memory updates on each debugging command, the speed of the debugger may be slower
due to the size of external data memory being larger than the internal data memory.
Therefore, the debugger has a button z for updating the value of external data memory.
As in section7.1 ‘IData Memory Window,’ if the user changes the value of external data

memory in the debugger, the real value of iMCU7100API board will also change.

7.3 Code Memory Window

The code memory window shows the value of code memory (0xFFOO00 ~ OxFFFFFF). This

window is for reading only, it cannot be modified.

Code Memory

fat Address!

2] a][s] 12

Address | oizz | 4567 | 89ar | coEF | ~
0=000000 - 02126A7& GBAFCOOPD 0O17BFF7A  OE79E77E
0=000010 - 007F0412 095D786E  7C007D01  7EFF7ACQE
0=000020 79BB7E00  7F041209 SD7&727C  007DOLTE
0=000030 :  FF7A0E79 EBF7E00FF  0412095D  787&7C00
0=000040 : 7D017BFF 7AOE79C3  7EO07FO06  12095D78
0=000050 - 7C7CO007D  017EFF7A  OEF9C97E  O07F0612
0=000060 095D7884 7CO07D01  7EFF7A0E  79D17E0Q
0=000070 7F081209 G5D121409 121A4F0FE 01740079
0=000080 : 76121932 7BO17400 796E1219 E37B0174
0=000090 : 00797212 19F67B0O1  7AOOD796A 1219CF7E
0=0000a0 : 0F017510 00751184 7EO17&00 797C1203

[Fig.7.5] Code Memory window
As in the section7.2 External Data Memory Window, the code memory window has a button for

g_ updating the value of code memory.

7.4  Flash Memory Window
7.4.1  Code Memory Domain

In the flash memory window, if the ‘Data memory’ option is unchecked, it will shows the

© Copyright 2012 WiZnet Co.,Ltd. All rights reserved. Ver. 1.1
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value of code memory (OxFFO000 ~ OxFFFFFF). Basically it is same the ‘Code Memory Window’

but it can modify the value with flash write button.

Start Address: [0xFFO000 End Address: [0xFFFFFF

Binjini-h |

Data memory

Address 0123 4567 894B CDEF A
0xff0000 : 80008000 02112800 08FC9Cl1l4  20FEFELS
0xf£0010 : E0861AEC DCDC1D3A 0BF94160 EBEDDO600
O=xf£0020 : DF008C80 FAFE94E2 FAE7FS8FF  SAFFA7DS
0xf£0030 : B603FF74 FFSFDACA FF8D88F9 SE3DBO9A
Oxf£0040 : 90EQEE62  91AFSEB? 72FDFFBS  8F90FD90
0xf£0050 : B8B7FF40 F98CC082 96C89CBC  SFASEB30
Oxff0060 : FFDFSFFF EB6C4B800 66F6BOD?7 E&BDDD99
0=f£0070 : FEB77298 00378124 DOBB9028 868D9AS0
0xf£0080 : D6FF848C  30E6AES88  99FESEEE ECFFCAF9
0xf£0090 : 8BBF7FD4  B7FBFFDS  S54FD73E0 FFBBELF7
0xff00a0 : 927EFF66  3F76FFE?7 F9BDFBO4  168A83EF
O0xf£00b0 1FF313BD B1EEBB08 9DF5C8A4 FDOO0DAOD
Oxff00c0 : C6C4BA7E B65A49344  7DF7D782  96EE3ESS
Oxf£00d40 : 9EFDD7FF  2EDDAFDF  S1F700Ce 70270000
L0xff00e0 - 92934012 ASFDO010 60B9409F AEF430C2 e

" Elsearch | &]Local V... &l Global ... | & Symbol [Z]IData M.., | [E] Externa...| (] Flash M... [€]Code M.,

[Fig.7.6] Flash memory window for code memory

The basic interface of the flash memory window is the same as other memory windows. But

it has the flash write button H"}é. which writes the whole value of flash memory window to

|

the flash memory of iMCU7100API. Also it has a button |

memory.

7.4.2 Data Memory Domain

for updating the value of flash

Start Address: |:| End Address: l:l v Data memaory
ZlEERE

Address

0=££0000 :
0=x££0010 :
0=f£0020 :
0=££0030 :
0=f£0040 :
0=££0050
0=f£0060 :
0=££0070 :
0=f£0080 :
0=££0090 :
O0=f£00a0 :
0=f£00b0
0=f£00c0 :
0=££00d0
Oxf£00e0
0=f£00£0 :

0123
80008000
E0861AEC
DF008C80
BE603FF74
90EQEE62
B8B7FF40
FFDFSFFF
FEB?77298
DEFFB48C
8BBF7FD4
927EFF66
1FF393BD
C6C4BA7E
9EFDD7FF
82934012
00C77D04

4567
02112800
DCDD1D3E
FAFE94E2
FF9FDACA
91AF9EB?
F98CCo82
B6C4B200
00378124
30E6AEBS
B7FEBFFDS
3F76FFE?
B1EEBBE238
B6SA9344
2EDDAFDF
ABFDOO1D0
081B2908

89AB
08FCSC14
0BF94160
FAE7F8FF
FF8D88F9
72FDFFBS
96C89CEC
66F6B0D7
DOBEB90238
99FESFEE
S4FD73E0
F9EDFBO4
9DFSC8A4
7DF7D782
91F700Ce
60B9409F
42C2B800

CDEF
20FEFB18
BBEDDO600
S8AFFA7DS
SE3DB09A
8F90FD90
SFA9EBE30
E6EDDD99
868D9AB0D
ECFFCAF9
FFEBE1F7
168A83BF
FDOODADD
96EE3ESS
70270000
AEF430C2
oooooooo
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[Fig.7.6] Flash memory

window for data memory

If the ‘Data memory’ option is checked, it will shows the value of flash data memory (0x00

~ OxFF). It can modify the value with flash write button. The basic interface of the flash

memory window is the same as other memory windows. But it has the flash write button

‘-Zl. which writes the whole value of flash memory window to the flash memory of

iMCU7100API. Also it has a button

~a

m- for updating the value of flash memory.
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